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Chapter 1: Introduction 
This manual will guide you through the process of validating the DatPass and 
MicroLab Plus software package to GMP 4 and FDA Title 21 CFR Part 11 guidelines. 
This manual will provide users with a test plan for their own performance and 
operational qualification of DatPass and MicroLab Plus.  
The manual comprises two main sections. The first section describes the relevant 
sections of the FDA Title 21 CFR Part 11 and the implementation of these sections in 
the Fourier Systems software package. The second section provides the necessary 
test sheets for DatPass and MicroLab Plus.  
It is important to understand that the implementation of these guidelines is not the 
sole responsibility of Fourier Systems. The software user must undertake a large 
portion of the responsibility through the appropriate validation tests. 
 
The software package consists of two programs:  
• DatPass – MicroLab and MicroLab Plus administration application 
• MicroLab Plus – Data acquisition and analysis application  
 
To validate the software package, start by testing DatPass, followed by MicroLab 
Plus. 
Some of these tests assume that the user is familiar with the Windows interface in 
addition to the DatPass and MicroLab Plus software. 
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Chapter 2: What is Title 21 CFR Part 11? 
The Food and Drug Administration (FDA) issued the regulations Title 21 Code of Federal 
Regulations Part 11. These regulations provide criteria for acceptance by FDA, under certain 
circumstances, of electronic records, electronic signatures, and handwritten signatures 
executed to electronic records as equivalent to paper records and handwritten signatures 
executed on paper. The regulations apply to all FDA program areas, and are intended to 
permit the widest possible use of electronic technology, compatible with FDA’s responsibility 
to promote and protect public health. Part 11 applies to any record governed by an existing 
FDA predicate rule that is created, modified, maintained, archived, retrieved, or transmitted 
using computers and/or saved on durable storage media. 

Title 21 CFR Part 11 Definitions 

Electronic Record 
Any combination of text, graphics, data, audio, pictorial or other information representation in 
digital form, that is created, modified, maintained, archived, retrieved or distributed by a 
computer system. 

Electronic Signature 
A computer data compilation of any symbol or series of symbols, executed, adopted or 
authorized by an individual to be the legally binding equivalent of the individual’s handwritten 
signature. 

Digital Signature 
An electronic signature based upon cryptographic methods of originator authentication, 
computed by using a set of rules and a set of parameters such that the identity of the signer 
and the integrity of the data can be verified. 

Closed System 
An environment in which system access is controlled by persons who are responsible for the 
content of electronic records that is on the system. 

Open System 
An environment in which system access is not controlled by persons who are responsible for 
the content of electronic records that is on the system. 

Standard Operating Procedures (SOPs) 
Guidelines and rules defined by the organization implementing Title 21 CFR Part 11 
compliance to instruct users what they are and are not permitted to do and how they are to 
perform the relevant tasks. 

Fourier Systems' Software 
The dual program software package achieves compliance with FDA Title 21 CFR Part 11 
with: MicroLab Plus and DatPass. The DatPass software is the administration software, which 
includes features that define the users that can log into the MicroLab Plus software, their 
passwords and the digital signatures the users are permitted to sign data within electronic 
records (files). The MicroLab Plus software is used to access the electronic records, display 
the logger data, analyze the data and allow the user to add the appropriate digital signatures 
to the electronic records, in addition to other features. An additional security feature is the 
serial port dongle, without which the MicroLab Plus and DatPass software packages will not 
operate. 
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Chapter 3: Compliance with Title 21 CFR Part 11 
 
Title 21 CFR Part 11 Requirements Comments on Compliance or Requirements 
§11.10 Controls for Closed Systems 
(a) Validation of systems to ensure 

accuracy, reliability, consistent 
intended performance, and the 
ability to discern invalid or altered 
records. 

Yes MicroLab Plus will not open invalid or 
altered data.  

(b) The ability to generate accurate 
and complete copies of records in 
both human readable and 
electronic form suitable for 
inspection, review, and copying 
by the agency. 

Yes To ensure data integrity, MicroLab 
Plus stores data with specific formats 
(mlb and mpj). Data can be exported 
to Excel™ and stored in common 
formats, such as an Excel workbook 
or for example comma delimited or 
tab delimited. Only through the (mlb) 
and (mpj) formats can data be read 
back into MicroLab Plus and only 
these formats support electronic 
signatures. 

(c) Protection of records to enable 
their accurate and ready retrieval 
throughout the records retention 
period. 

N/A The customer chooses which data 
directory to save files to. Otherwise, 
the default directory C:\Program 
Files\Fourier Systems\MicroLab Plus 
for DatPass\MicroLab Data is used. 
System owners must establish their 
own SOPs to protect and restore data 
files. 

(d) Limiting system access to 
authorized individuals. 

Yes For limited access, the customer must 
purchase a valid software license and 
dongle device, preventing access to 
unauthorized users. 

(e) Use of secure, computer-
generated, time- stamped audit 
trails to independently record the 
date and time of operator entries 
and actions that create, modify, or 
delete electronic records. Record 
changes shall not obscure 
previously recorded information. 
Such audit trail documentation 
shall be retained for a period at 
least as long as that required for 
the subject electronic records and 
shall be available for agency 
review and copying. 

Yes Every action that generates or alters 
an electronic record (mlb or mpj), 
automatically generates an entry into 
an encrypted log file, which can be 
used in audit trail. The entries are 
chronologically organized and cannot 
be edited or deleted. The entries can 
only be viewed using the DatPass 
software. It is the system owner's 
responsibility to create SOPs to 
protect and restore audit trail files. 

(f) Use of operational system checks 
to enforce permitted sequencing 
of steps and events, as 
appropriate 

Yes A smart and user friendly interface 
ensures all MicroLab Plus operations 
follow a specified order. This ensures 
all stages are followed.  

(g) Use of authority checks to ensure 
that only authorized individuals 
can use the system, electronically 
sign a record, access the 
operation or computer system 
input or output device, alter a 
record, or perform the operation 
at hand. 

Yes When using MicroLab Plus, users 
logon with a valid username and 
password. Further security is ensured 
by a Fourier Dongle having to be 
connected to the workstation. All 
actions are recorded in an encrypted 
audit trial log file. 
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Title 21 CFR Part 11 Requirements Comments on Compliance or Requirements 
(h) Use of device (e.g. terminal) 

checks to determine, as 
appropriate, the validity of the 
source of data input or 
operational instruction. 

Yes MicroLab Plus checks the status of 
the logger at each communication – 
errors are automatically reported. 

(i) Determination that persons who 
develop, maintain, or use 
electronic record/electronic 
signature systems has the 
education, training, and 
experience to perform their 
assigned tasks. 

N/A System owners must provide their 
authorized users with relevant 
training. 

(j) The establishment of, and 
adherence to, written policies that 
hold individuals accountable and 
responsible for actions initiated 
under their electronic signatures, 
in order to deter record and 
signature falsification. 

N/A System owners must develop written 
policy in which reliability and 
responsibility of each user is 
documented. 

(k) Use of appropriate controls over 
systems documentation including: 

  

(k)(1) Adequate controls over the 
distribution of, access to, and use 
of documentation for system 
operation and maintenance. 

N/A The MicroLab Plus and DatPass 
Package for Title 21 CFR Part 11 
compliance are supplied with detailed 
user guides and help files, which can 
be used to create SOP. Distribution, 
access and implementation of this 
documentation are the responsibility 
of the system owner. 

(k)(2) Revision and change control 
procedures to maintain an audit 
trail that documents time- 
sequenced development and 
modification of systems 
documentation. 

N/A This is the responsibility of the system 
owner. 

§11.30 Controls for Open Systems 
 Persons who use open systems 

to create, modify, maintain, or 
transmit electronic records shall 
employ procedures and controls 
designed to ensure the 
authenticity, integrity, and, as 
appropriate, the confidentiality of 
electronic records from the point 
of their creation to the point of 
their receipt. Such procedures 
and controls shall include those 
identified in §11.10, as 
appropriate, and additional 
measures such as document 
encryption and use of appropriate 
digital signature standards to 
ensure, as necessary under the 
circumstances, record 
authenticity, integrity, and 
confidentiality. 

N/A MicroLab Plus has been implemented 
as a closed system. 
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Title 21 CFR Part 11 Requirements Comments on Compliance or Requirements 
§11.50 Signature Manifestations 
(a) Signed electronic records shall 

contain information associated 
with the signing that clearly 
indicates all of the following: 

  

(a)(1) The printed name of the signer; Yes Stored and printed data contains: 
User login name, time/date stamp, 
and user signature meaning(s).  

(a)(2) The date and time when the 
signature was executed; 

Yes  

(a)(3) The meaning (such as review, 
approval, responsibility, or 
authorship) associated with the 
signature 

Yes  

(b) The items identified in paragraphs 
(a)(1),(a)(2), and (a)(3)of this 
section shall be subject to the 
same controls as for electronic 
records and shall be included as 
part of any human readable form 
of the electronic record (such as 
electronic display or printout). 

Yes Electronic signatures in MicroLab 
Plus are subject to the same 
requirements as electronic records. 
Electronic signatures can be viewed 
electronically and can be included on 
a printout. 

§11.70 Signature/Record Linking 
 Electronic signatures and 

handwritten signatures executed 
to electronic records shall be 
linked to their respective 
electronic records to ensure that 
the signatures cannot be excised, 
copied or otherwise transferred so 
as to falsify an electronic record 
by ordinary means. 

Yes In MicroLab Plus, raw data and 
electronic signatures are permanently 
linked in a single file, and as such 
cannot be edited, deleted or 
separated. 

§11.100 General Requirements 
(a) Each electronic signature shall be 

unique to one individual and shall 
not be reused by, or reassigned 
to, anyone else. 

Yes DatPass software contains an 
authorized user list containing login 
name, password, and meanings list, 
making every user unique to the 
system. 

(b) Before an organization 
establishes, assigns, certifies or 
otherwise sanctions an 
individual's electronic signature, 
or any element of such electronic 
signature, the organization shall 
verify the identity of the individual. 

N/A This is the responsibility of the system 
owner. 

(c) Persons using electronic 
signatures shall, prior to or at the 
time of such use, certify to the 
agency that the electronic 
signatures in their system, used 
on or after August 20, 1997, are 
intended to be the legally binding 
equivalent of traditional 
handwritten signatures. 

N/A This is the responsibility of the system 
owner. 
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Title 21 CFR Part 11 Requirements Comments on Compliance or Requirements 
(c)(1) The certification shall be 

submitted in paper form, and 
signed with a traditional 
handwritten signature, to the 
Office of Regional Operations 
(HFC-100),5600 Fishers Lane, 
Rockville, MD 20857.  

N/A This is the responsibility of the system 
owner. 

(c)(2) Persons using electronic 
signatures shall, upon agency 
request, provide additional 
certification or testimony that a 
specific electronic signature is the 
legally binding equivalent of the 
signer's handwritten signature. 

N/A This is the responsibility of the system 
owner. 

§11.200 Electronic Signature Components and Controls 
(a) Electronic signatures that are not 

based upon biometrics shall: 
  

(a)(1) Employ at least two distinct 
identification components such as 
an identification code and 
password. 

Yes DatPass Software for Title 21 CFR 
Part 11 compliance uses a unique 
dual component combination: Login 
username and password. Every login 
and new digital signature with 
MicroLab Plus requires a valid 
username and password. MicroLab 
Plus enforces the user to re-logon 
after a time period, which is defined 
by the administrator via the DatPass 
software. 

(a)(1)(i) When an individual executes a 
series of signings during a single, 
continuous period of controlled 
system access, the first signing 
shall be executed using all 
electronic signature components; 
subsequent signings shall be 
executed using at least one 
electronic signature component 
that is only executable by, and 
designed to be used only by, the 
individual 

Yes  

(a)(1)(ii) When an individual executes one 
or more signings not performed 
during a single continuous period 
of controlled system access, each 
signing shall be executed using 
all of the electronic signature 
components. 

Yes  

(a)(2) Be used only by their genuine 
owners; 

N/A Information confidentiality is the 
responsibility of the system owner 
and users. 

(a)(3) Be administered and executed to 
ensure that attempted use of an 
individual's electronic signature 
by anyone other than its genuine 
owner requires collaboration of 
two or more individuals. 

N/A Information confidentiality is the 
responsibility of the system owner 
and users. 
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Title 21 CFR Part 11 Requirements Comments on Compliance or Requirements 
(b) Electronic signatures based upon 

biometrics shall be designed to 
ensure that they cannot be used 
by anyone other than their 
genuine owners. 

N/A Biometrics are not the basis of 
electronic signatures generated by 
DatPass software for Title 21 CFR 
Part 11 compliance.  

§11.300 Controls for Identification Codes/Passwords 
 Persons who use electronic 

signatures based upon use of 
identification codes in 
combination with passwords shall 
employ controls to ensure their 
security and integrity. Such 
controls shall include: 

  

(a) Maintaining the uniqueness of 
each combined identification code 
and password, such that no two 
individuals have the same 
combination of identification code 
and password. 

Yes Since every user is unique in the 
MicroLab Plus and DatPass systems, 
duplicate combinations of username 
and password are impossible. 

(b) Ensuring that identification code 
and password issuances are 
periodically checked, recalled, or 
revised, (e.g. to cover such 
events as password aging). 

Yes Adequate aging of passwords is the 
responsibility of the system owner. 
MicroLab Plus allows authenticated 
users to change their own logon 
password.  

(c) Following loss management 
procedures to electronically 
deauthorize lost, stolen, missing, 
or otherwise potentially 
compromised tokens, cards, and 
other devices that bear or 
generate identification code or 
password information, and to 
issue temporary or permanent 
replacements using suitable, 
rigorous controls. 

N/A Unauthorized access is vetoed by the 
DatPass software since an 
administrator can disable or remove 
any user from the system. 

(d) Use of transaction safeguards to 
prevent unauthorized use of 
passwords and/or identification 
codes, and to detect and report in 
an immediate and urgent manner 
any attempts at their 
unauthorized use to the system 
security unit, and, as appropriate, 
to organizational management.  

Yes All unsuccessful logons are recorded 
in the audit trail log file. 

(e) Initial and periodic testing of 
devices, such as tokens or cards, 
that bear or generate 
identification code or password 
information, to ensure that they 
function properly and have not 
been altered in an unauthorized 
manner. 

N/A This is the responsibility of the system 
owner. 

References 
For further information on FDA Title 21 CFR Part 11, please visit the FDA website: 
www.fda.gov 
For FDA guidance documents: 
www.fda.gov/ora/compliance_ref/part11/ 
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Chapter 4: DatPass Validation Tests 
 

1 - Initial Login 
Ensure that the DatPass security plug is connected to your computer’s USB port. 
Note: After installation, the first user to login to the DatPass software is automatically 
assigned the user name Admin. He is classified as an administrator.  
 

Test # Test Description Expected Result Result 
1.1 Double click the DatPass 

icon on the Desktop. 
Verify that the User Login dialog box 
opens. 

 

1.2 Click New User in the login 
window. 

a. Verify that the New User Login 
window opens. 

b. Verify that the New User drop-
down menu displays the Admin 
user name. 

 

1.3 a. Populate the New User 
ID, Confirm User ID, 
New Password and 
Confirm Password fields, 
and click OK. 

b. Exit the DatPass 
software. 

c. Launch the DatPass 
software. 

a. Once DatPass is launched, 
verify that the User Login 
window opens. 

b. Verify that the newly created 
User ID and User Password are 
correct (click OK and verify 
successful login to DatPass). 

 

 

2 - File Menu 
 
Test # Test Description Expected Result Result 
2.1 On the File menu, click 

Open. 
Navigate to: 
My Documents\Fourier 
Systems\DatPass.  
Note: You will only find files 
saved in this directory if 
data, such as the Audit Trail 
log, has been previously 
saved.  

a. Verify that the Open 
dialog box opens.  

b. Select a file to open, and 
click Open. 

c. Verify that the file opens, 
and the table data is 
displayed in the main 
DatPass window.  

 

2.2 On the File menu, click 
New. 

Verify that the DatPass main window 
is clear i.e. there is no Audit Trail log 
data. 

 

2.3 On the File menu, click 
Print. 
Note: For this action to 
succeed, the main DatPass 
window must be populated 
with Audit Trail log data.  

Verify that the Print Dialog dialog 
box opens. 

 

2.4 On the File menu, click 
Print Setup. 

Verify that the Print Setup dialog box 
opens. 
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Test # Test Description Expected Result Result 
2.5 On the File menu, click Log 

off. 
Verify that the User Login dialog box 
opens. 

 

3 - Administration 
 

Test # Test Description Expected Result Result 
3.1 On the Administration 

menu, click User 
Administration.  

a. Verify that the User 
Administration dialog box opens. 

b. Verify that Admin appears under 
the User Name tab and 
Administrator appears under the 
Group tab.  

 

3.1.1 a. In the User 
Administration dialog 
box, click Add User. 

b. Enter a new user name 
in the User Name field. 

c. Select a Group from the 
Group drop-down menu: 
Administrator, Approver, 
or User. 

Under the Login Settings 
heading: 
d. Enter a number in the 

Password min length 
field (for example, 4). 

e. Enter a number in the 
User ID min length field 
(for example, 4). 

f. Enter number of days in 
the Password expiration 
time (days) field (for 
example, 1). 

g. Use the drop-down 
menu in the Inactivity 
Timeout field to select 
the duration (for 
example, 00:05:00). 

h. Click OK. 

Verify that a new user has been 
added to the User Administration 
dialog box, listing the correct User 
Name and Group. 

 

3.1.2 a. Launch the DatPass 
software and add click 
New User.  

b. Using the new user 
account created in test 
3.1.1, fill in the New User 
ID, Confirm New User 
ID, New Password and 
Confirm Password fields. 

c. Click OK.  

Verify that the DatPass software 
opens. 
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Test # Test Description Expected Result Result 
3.1.3 Launch the DatPass 

software. In the User Login 
dialog box: 
a. Enter an incorrect user 

name and a correct 
password. 

b. Enter a correct user 
name and an incorrect 
password. 

c. Enter an incorrect user 
name and password.  

Verify that in all three login tests, the 
DatPass software does not open. 

 

3.2 In the User Administration 
dialog box, select the newly 
added user (see test 3.1.1) 
and click Properties. 

a. Verify that the User Properties 
dialog box opens. 

b. Verify that the properties entered 
when adding the user (in test 
3.1.1) are correct. 

 

3.2.1 a. In the User Properties 
dialog box, change the 
user group using the 
drop-down menu in the 
Group field. For 
example, from User to 
Approver). 

b. Click OK.  

Verify that the user group was 
successfully changed by reopening 
the User Properties dialog box and 
checking the Group field.  

 

3.2.2 a. In the User Properties 
dialog box, change the 
Login Settings. 

b. Click OK. 

Verify that the Login Settings were 
successfully changed by reopening 
the User Properties dialog box and 
checking the relevant Login 
Settings.  

 

3.3 In the User Administration 
dialog box, select a user and 
click Deactivate. 

Verify that the user icon is now 
marked with a white cross in a red 
background, as follows:   

 

3.3.1 Open the DatPass software 
and attempt to login with the 
user name and password of 
the newly deactivated user.  

Verify that a dialog box opens with 
the message:  
Your user account was deactivated. 
Please refer to your system 
administrator. 

 

3.3.2 a. In the User 
Administration dialog 
box, select the 
previously deactivated 
user and click Activate. 

b. Exit DatPass, then 
reopen DatPass and 
login with the user name 
and password of the 
newly activated user. 

Verify that you are able to 
successfully login to DatPass.  
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Test # Test Description Expected Result Result 
3.3.3 a. In the User 

Administration dialog 
box, select a user and 
click Renew Password. 

b. Exit DatPass, and then 
reopen DatPass and 
attempt to login with that 
user. 

a. Verify that a new DatPass dialog 
box opens with the message:  
Your password was reset. 
Please enter a new password. 

b. After clicking OK, verify that a 
new Change Password dialog 
box opens. 

 

3.3.4 a. In the Change Password 
dialog box, enter a new 
password and then 
confirm this password. 

b. Click OK. 

Verify that the DatPass software 
opens. 

 

3.3.5 Launch the DatPass 
software and login using the 
user name and new 
password created in step 
3.3.4. 

Verify that the DatPass software 
opens. 

 

3.4 On the Administration 
menu, click Group 
Administration.  

a. Verify that the Group 
Administration dialog box opens. 

b. Verify that the group names 
User, Approver and 
Administrator are displayed. 

 

3.4.1 In the Group Administrator 
dialog box, click Add Group.

Verify that the Group Properties 
dialog box opens. 

 

3.4.2 a. In the Group Properties 
dialog box, enter a new 
name in the Group 
Name field. 

b. Click the New check box.
c. Click OK. 

a. Verify that the Group 
Administration dialog box opens. 

b. Verify that the newly created 
group is displayed in the Group 
Name list. 

 

3.4.3 In the Group Administrator 
dialog box, select the newly 
created group and click 
Properties. 

Verify that there is only one check 
box selected (in this case, New).  

 

3.4.4 In the Group Administrator 
dialog box, select one of the 
listed groups and click 
Remove Group. 
Note: You will not be able to 
remove a group if there are 
still users who are members 
of this group. 

a. Verify that a dialog box opens 
with the message:  
Are you sure you want to 
remove <Group Name> group? 

b. Click Yes. 

 

3.4.5 On the Administration 
menu, click Group 
Administration.  

Verify that the group you have 
removed is no longer displayed in 
the Group Name list. 
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4 - Help 
 

Test # Test Description Expected Result Result 
4.1 On the Help menu, click 

About DatPass.  
a. Verify that the About DatPass 

dialog box opens. 
b. Verify that the DatPass version 

number and copyright are 
displayed. 

c. Verify the link 
http://www.fouriersystems.com/ 
works. 

 

 

5 – Main Toolbar Icons 
 

Test # Icon Test and Expected Result Result 
5.1 Open 

  

Refer to test 2.1.  

5.2 Print 

  

Refer to test 2.3.  

5.3 User Administration 

  

Refer to tests 3.1 to 3.3.  

5.4 Group Administration 

  

Refer to test 3.4.   

5.5 Refresh  

  

a. Wait several minutes (for users 
to perform actions) and click 
Refresh. 

b. Verify that the Audit Trail data 
has been refreshed (you will see 
new actions added to the table). 

 

5.6 Calendar 

 

Use the drop-down menu to open 
the calendar and select a date. 
Verify that the data from this date is 
displayed on your screen. 
Note: Only those dates with 
recorded data will be displayed.  
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Chapter 5: MicroLab Plus Validation Tests 
 

1 - Login 
 

Test # Test Description Expected Result Result 
1.1 a. Launch the MicroLab 

Plus software. The User 
Login dialog box opens. 

b. In the User ID field, enter 
the User ID created in 
test 1.3 of the DatPass 
Validation Test. 

c. In the User Password 
field, enter an incorrect 
password. 

Verify that the MicroLab Plus 
software does not open and an 
Incorrect Password message 
window opens. 

 

1.2 a. In the User Login dialog 
box, in the User ID field, 
enter an incorrect User 
ID.  

b. In the User Password 
field, enter the User 
Password created in test 
1.3 of the DatPass 
Validation Test. 

Verify that the MicroLab Plus 
software does not open and an 
Incorrect User ID message 
window opens. 

 

1.3 In the User Login dialog box, 
enter an incorrect User ID 
and User Password.  

Verify that the MicroLab Plus 
software does not open and an 
Incorrect User ID message 
window opens. 

 

1.4 In the User Login dialog box, 
login using the User ID and 
User Password created in 
test 1.3 of the DatPass 
Validation Test. 

Verify that the MicroLab Plus 
software is launched. 

 

 

2 - File Menu 
 

Test # Test Description Expected Result Result 
2.1 a. On the File menu, click 

Open. 
b. In the Open File 

dialog box, select 
a Unit ID from the 
drop-down menu. 

c. Define the date 
range for the file 
to be opened, 
using From and 
To and click OK. 

d. In the Advanced Open 
dialog box, select the 

a. Verify that the graph 
opens in the Offline 
Graph window in 
MicroLab Plus. 

b. Verify that the graph 
data is displayed 
according to the 
parameters set in test 
2.1c and 2.1d.  
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Test # Test Description Expected Result Result 
Display rate from the 
drop-down menu and 
select either the Average 
or Close sample radio 
buttons.  

e. Click OK. 
2.2 On the File menu, click 

Open a Report.  
In the Open dialog box, 
select a Report file to open 
and click Open. 
Note: This test can only be 
performed if a report file has 
been saved. Save a report 
file and if necessary, return 
to this test.  

Verify that the Report window 
opens. 

 

2.3 a. Ensure that there is a 
graph open in the Offline 
Graph window.  

b. On the File menu, click 
Clear.  

Verify that the graph has been 
cleared and the Offline Graph 
window is empty. 

 

2.4 On the File menu, click 
Print. 

Verify that the Print options dialog 
box opens. 

 

2.4.1 In the Print options dialog 
box, click the Graph radio 
button. 

Verify that the Report data 
selection option is disabled. 

 

2.4.2 In the Print options dialog 
box:  
a. Click the Graph radio 

button. 
b. Click Print. 

Verify that the Print dialog box 
opens. 

 

2.4.2.1 In the Print dialog box, 
confirm that the correct 
printer is selected in the 
Name drop-down menu and 
click OK. 

Verify that the graph was printed 
at the selected printer.  

 

2.4.3 In the Print options dialog 
box: 
a. Click the Table radio 

button. 
b. Under the Report data 

selection heading, 
ensure the Print all data 
check box is selected.  

c. Click Print. 

Verify that the Print dialog box 
opens. 

 

2.4.3.1 In the Print dialog box, 
confirm that the correct 
printer is selected in the 
Name drop-down menu and 
click OK. 

Verify that the graph was printed 
with all of its data (as defined in 
test 2.4.3), at the selected printer. 

 

2.4.4 In the Print options dialog 
box: 
a. Click the Table radio 

Verify that the Print dialog box 
opens.  
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Test # Test Description Expected Result Result 
button. 

b. Under the Report data 
selection heading, 
ensure the Print all data 
check box is not 
selected, thereby 
enabling the From and 
To fields. 

c. Using the From and To 
fields, define the date 
and time range to print. 

d. Click Print. 
2.4.4.1 In the Print dialog box, 

confirm that the correct 
printer is selected in the 
Name drop-down menu and 
click OK. 

Verify that the graph was printed 
with the specific date and time 
range (as defined in test 2.4.4), at 
the selected printer. 

 

2.5 On the File menu, click 
Print Setup. 

Verify that the Print Setup dialog 
box opens. 

 

2.6 On the File menu, click 
Display Properties.  

Verify that the Display properties 
dialog box opens. 

 

2.6.1 Under the Decimal place 
settings heading in the 
Display Properties dialog 
box: 
a. Change the 

Temperature data field 
to 3. 

b. Change the Humidity 
data field to 2. 

c. Change the External 
data field to 1. 

d. Click OK. 

Verify that in the data table in the 
Offline Graph window, the decimal 
places for the temperature and 
humidity data (and any external 
sensors) have been updated 
accordingly.  

 

2.6.2 In the Display properties 
dialog box, under the Date 
format settings heading are 
four options for the date 
format. 
Click on any one of the 
formats not already 
selected.  

a. Verify that for the graph in the 
Offline Graph window, the 
Time (x) axis has been 
updated accordingly.  

b. Verify that for the data table in 
the Offline Graph window, the 
Time (Date) column has been 
updated accordingly. 
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Test # Test Description Expected Result Result 
2.7 a. Ensure that the 

MicroLog Receiver is 
setup, with at least two 
Cradle units wirelessly 
connected to the 
MicroLab Plus software 
and identified in the 
Meters view window.  

b. On the File menu, click 
Select Active Cradles. 

c. In the Active Cradles 
Selections dialog box, 
click the Custom radio 
button. Enter the Unit ID 
of the Cradle units you 
wish to deactivate and 
click OK. 

Verify that in the Meters view 
window, the Cradle unit you 
deactivated is in fact greyed out. 

 

2.8 On the File menu, click Log 
Off. 

Verify that the User Login dialog 
box opens. 
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3 - View Menu 
 

Test # Test Description Expected Result Result 
3.1 On the View menu, click 

Display Offline Graph.  
Verify that the Offline Graph 
window opens. 

 

3.2 On the View menu, click 
Meters View. 

Verify that the Meters View 
window opens. 

 

3.3 On the View menu, click 
Display Multiple Graph 
View. 

Verify that the Display Multiple 
Graph View window opens. 

 

3.4 On the View menu, click 
Display Cradle Map. 

Verify that the Cradle Map window 
opens. 

 

 

4 – Offline Graph Menu 

Note: In order to perform the tests in this section, a graph must be displayed in the 
Offline Graph window.  
 

Test # Test Description Expected Result Result 
4.1 a. On the Offline Graph 

menu, click Graph 
Properties. 

b. Ensure that Time is 
selected in the Select 
axis drop down menu.  

c. Ensure the Auto scale 
check box is not 
selected, thereby 
enabling the From and 
To fields. 

d. Using the From and To 
fields, define a new date 
and time range. 

e. Click OK. 

Verify that the time scale of the 
graph in the Offline Graph window 
has been updated accordingly. 

 

4.1.1 a. In the Graph properties 
dialog box, click Set 
default zoom. 

b. In the Default zoom 
setting dialog box, enter 
a time range in the Start 
and End fields.  

c. Click Set. 
d. Click the Use default 

zoom check box. 
e. Click OK. 

Verify that the time scale of the 
graph in the Offline Graph window 
has been updated accordingly. 

 



 - 20 - 

Test # Test Description Expected Result Result 
4.1.2 a. In the Graph properties 

dialog box, select 
Temperature in the 
Select axis drop-down 
menu. 

b. The Min and Max 
temperature 
fields are now 
active. Enter –26 
in the Min field 
and 22 in the 
Max field. 

c. Click OK. 

Verify that the temperature scale 
of the graph in the Offline Graph 
window has been updated 
accordingly. 

 

4.1.3  a. In the Graph properties 
dialog box, click the 
Lines tab. 

b. Select Time in the Select 
plot drop-down menu. 

c. Change the X Axis color 
to red, by using the Color 
drop-down menu. 

Verify that the Time axis of the 
graph in the Offline Graph window 
is now red.  

 

4.1.4 a. In the Graph properties 
dialog box, click the 
Lines tab. 

b. Select Temperature in 
the Select plot drop-
down menu. 

c. Under the Line heading, 
ensure the Visible check 
box is selected. 

d. Change the Temperature 
axis color to green, using 
the Color drop-down 
menu. 

e. Using the Style drop-
down menu, select the 
solid line option. 

f. Using the Weight drop-
down menu, select the 
thinnest line option. 

In the graph in the Offline Graph 
window, verify that the 
Temperature axis is green and the 
line plotting the temperature data 
is green, solid and thin.  

 

4.1.5 a. In the Graph properties 
dialog box, click the 
Lines tab. 

b. Select Humidity in the 
Select plot drop-down 
menu. 

c. Under the Line heading, 
ensure the Visible check 
box is selected. 

d. Change the Humidity 
axis color to yellow, 
using the Color drop-
down menu. 

In the graph in the Offline Graph 
window, verify that the Humidity 
axis is yellow and the line plotting 
the humidity data is yellow, solid 
and thin.  
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Test # Test Description Expected Result Result 
e. Using the Style drop-

down menu, select the 
solid line option. 

f. Using the Weight drop-
down menu, select the 
thinnest line option. 

4.1.6 a. In the Graph properties 
dialog box, click the 
Lines tab. 

b. Click Restore defaults. 

Verify that all axis and line defaults 
have been restored in the graph in 
the Offline Graph window.  

 

4.2 On the Offline Graph menu, 
click Export Graph to 
Excel. 

Verify that the displayed graph is 
exported to Excel. 

 

4.3 a. On the Offline Graph 
menu, click Zoom. 

b. Click down and hold the 
left mouse button and 
drag the Zoom cursor 
over the area of the 
graph to be zoomed.  

c. Release the left mouse 
button to set the zoom 
area. 

Verify that the selected area of the 
graph is zoomed in. 

 

4.4 a. On the Offline Graph 
menu, click Pan. 

b. Place the Pan cursor 
over the graph, hold 
down the left mouse 
button and proceed to 
pan the graph up, down, 
left and right.  

Verify that the graph pans up, 
down, left and right. 

 

4.5 On the Offline Graph menu, 
click Autoscale. 

Verify that the graph in the Offline 
Graph window is restored and 
displayed in full.  

 

4.6 a. On the Offline Graph 
menu, click Copy 
Graph.  

b. Paste the graph into 
another application such 
as Microsoft Office 
Word.  

Verify that the graph has been 
successfully copied.  

 

4.7 On the Offline Graph menu, 
click Dew Point and select 
Internal Temperature.  

Verify that the dew point is shown 
on the graph in the Offline Graph 
window. 
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5 – Cradle Map Menu 

Note: In order to perform the tests in this section, the Cradle Map window must be 
open.  
 

Test # Test Description Expected Result Result 
5.1 On the Cradle Map menu, 

click Display Toolbar. 
Verify that the toolbar is displayed 
at the bottom of the Cradle Map 
window. 

 

5.2 Click the Lock view icon in 
the toolbar, or click Lock 
view in the Cradle Map 
menu, to enable the rest of 
the toolbar icons. 

Verify that the entire Cradle Map 
toolbar is now enabled. 

 

5.3 a. Click the Add Cradle 
icon in the toolbar, or 
select Add cradle in the 
Cradle Map menu.  

b. Click the icon once per 
cradle to be added. Use 
the drop-down menu to 
add 5, 10 or 15 cradles 
at a time. 

a. Verify that cradles are added 
to the Cradle Map.  

b. Verify that inactive cradles are 
represented using the grey 

cradle icon . 
c. Verify that active cradles are 

represented using the green 

cradle icon . 

 

5.4 a. Click the Remove 
Cradle icon in the 
toolbar, or click Remove 
cradle in the Cradle 
Map menu.  

b. Click the icon once per 
cradle to be removed. 
Use the drop-down 
menu to remove 5, 10 or 
15 cradle at a time.  

Verify that cradles are removed 
from the Cradle Map in numerical 
order (from the last numbered 
icon). 

 

5.5 a. Click the Load Image 
icon in the toolbar, or 
select Load picture in 
the Cradle Map menu. 

b. In the Open dialog box, 
browse to the image you 
want to load and click 
Open. 

Verify that the selected image was 
opened in the Cradle Map window. 
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6 - Multiple Graphs Menu 

Note: In order to perform the tests in this section, you must be in Multiple Graphs 
View.  
 

Test # Test Description Expected Result Result 
6.1 a. On the Multiple Graphs 

menu, click Zoom. 
b. Click down and hold the 

left mouse button and 
drag the Zoom cursor 
over the area of the 
graph to be zoomed.  

c. Release the left mouse 
button to set the zoom 
area. 

Verify that the selected area of the 
graph is zoomed in. 

 

6.2 a. On the Multiple Graphs 
menu, click Pan. 

b. Place the Pan cursor 
over the graph, hold 
down the left mouse 
button and proceed to 
pan the graph up, down, 
left and right.  

Verify that the graph pans up, 
down, left and right. 

 

6.3 a. On the Multiple Graphs 
menu, click Display 
cursors. 

b. Drag the cursor left or 
right along the x axis of a 
graph in the Multiple 
Graphs window. 

Verify that the x and y coordinates 
displayed at the bottom of the 
graph change as the cursor is 
dragged left or right. 

 

6.4 On the Multiple Graphs 
menu, click Autoscale. 

Verify that all graphs in the 
Multiple Graphs window are 
restored and displayed in full.  

 

 

7 - Logger Menu 
Note: Ensure that the MicroLog and Cradle are connected to the PC and is 
recognized by the MicroLab Plus software. 
 

Test # Test Description Expected Result Result 
7.1 a. On the Logger menu, 

click Logger Setup. 
b. In the MicroLog info 

section of the Setup 
dialog box, enter a new 
name to identify the 
MicroLog in the 
Comment field.  

c. Click Send Setup.  

MicroLog Info Section Verification 
a. Enter the Setup dialog 

box and verify that the 
Comment field is 
correctly updated. 

b. Verify that the S/N is 
correct for the 
MicroLog that is 
currently connected to 
the MicroLab Plus.  

c. Verify that the 
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Test # Test Description Expected Result Result 
MicroLog software 
version number is 
displayed. 

d. Verify that the arrow on 
the Battery Level meter 
is located on the far 
right of the green bar. 

7.2 a. On the Logger menu, 
click Logger Setup. 

In the Setup section of the 
Setup dialog box:  
b. Click either the º C or º F 

radio button next to the 
Temperature unit 
heading.  

c. In the Interval 
(hh:mm:ss) field, select 
the time interval for 
MicroLog sampling (from 
10 secs to 2 hours). 

d. Click the Timer run check 
box. Using the Timer run 
date and time fields, set 
the time for the MicroLog 
to begin sampling.  

e. Click Send Setup.  

Setup Section Verification 
a. Enter the Setup dialog 

box. 
b. If the connected 

MicroLog comes with 
both Temperature and 
Humidity internal 
sensors, verify that 
both of the check 
boxes for these 
sensors are selected. 

c. If the connected 
MicroLog only comes 
with the Temperature 
internal sensor, verify 
that the check box for 
this sensor is selected 
and that the Humidity 
and External sensor 
check boxes are not 
selected (and N/A is 
displayed).  

d. If there is no Cradle 
contact connected, 
verify that the Cradle 
contact check box is 
not checked.  

e. Verify that when the 
Interval is adjusted 
(test 7.2c), so does the 
Recording time.  

f. Verify that all updates 
made in test 7.2 have 
been updated in the 
Setup dialog box.  

g. After exiting the Setup 
dialog box, download 
the MicroLog data and 
verify (in the data table) 
that the data date and 
time range, as well as 
the data interval, 
correspond with what 
you defined in Setup. 
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Test # Test Description Expected Result Result 
7.3 a. On the Logger menu, 

click Logger Setup. 
In the Alarm levels section of 
the Setup dialog box:  
b. Enter new Low and High 

values in the 
Temperature and 
Humidity fields.  

c. Click Send Setup. 
d. Open new data from the 

MicroLog into MicroLab 
Plus, so that the data is 
displayed in a graph in 
the Offline Graph 
window.  

e. Click the Show Alarm 

levels icon  in the 
MicroLab Plus tool bar. 
Select Temperature from 
the adjacent drop-down 
menu, then select 
Humidity.   

a. In the Offline Graph window, 
verify that the Low and High 
alarm levels for both 
Temperature and Humidity 
appear on the graph as a light 
blue and light red line 
respectively.  

b. Verify that these alarm levels 
correspond to the alarm levels 
previously defined in the 
Setup. 

  

 

7.3.1 a. On the Logger menu, 
click Logger Setup. 

In the Alarm levels section of 
the Setup dialog box:  
b. Click Cancel alarm 

levels to restore the 
default levels adjusted in 
test 7.3.  

c. Click Send Setup. 
d. Repeat tests 7.3d and 

7.3e above. 

a. In the Offline Graph window, 
verify that the Low and High 
alarm levels for both 
Temperature and Humidity 
appear on the graph as a light 
blue and light red line 
respectively. 

b. Verify that the default alarm 
levels have been restored as 
follows: 
Temperature: Low: -30 °C/-22 
°F, High: 50°C/122 °F 
Humidity: Low: 0, High: 100 

 

7.4 a. On the Logger menu, 
click Logger Setup. 

b. In the Setup dialog box, 
click Send Setup. 

 

a. Verify that the Reason Dialog 
box opens. Enter a reason for 
performing this action e.g. 
Test. 

b. Verify that the Status window 
opens and that all statuses are 
successfully sent (noted with a 
green check mark). A 
Completed status should 
appear at the bottom of this 
window.  

c. Click Close. 
 
Note: The Set Cradle status will 
only be sent if a Cradle is 
connected and recognized by 
MicroLab Plus.  

 



 - 26 - 

Test # Test Description Expected Result Result 
7.5 a. On the Logger menu, 

click Auto Setup. 
b. In the Auto Setup dialog 

box, select the number of 
units to set up and click 
Start. 

c. In the Setup dialog box, 
set up the cradle unit 
according to your needs 
and click OK. 

d. In the Auto Setup - Unit 1 
dialog box, click Send. 

e. Connect another unit to 
the PC and click Send. 

f. Once the data is sent, 
click Close. 

Verify that for each unit you setup, 
the setup was successful by 
connecting each unit to the PC 
and check the Setup status. 
 

 

7.6  On the Logger menu, click 
Set Celsius. 

Verify that the temperature data is 
shown in the MicroLog LCD 
display in Celsius.  

 

7.7 On the Logger menu, click 
Set Fahrenheit. 

Verify that the temperature data is 
shown in the MicroLog LCD 
display in Fahrenheit. 

 

7.8 On the Logger menu, click 
Com Setup. 
 

a. Verify that the Communication 
Setup dialog box opens. 

b. Verify that the MicroLog and 
Cradle you have connected to 
the PC is identified. The check 
box for the port to which the 
MicroLog is connected should 
be selected. Verify that the 
message Cradle with a 
MicroLog is connected 
appears. 

 

7.8.1 On the Logger menu, click 
Com Setup. 
In the Communication Setup 
dialog box, click Try to 
connect. 

a. Verify that the PC ports are 
being scanned. 

b. Verify that a confirmation 
message appears indicating 
that the MicroLog and Cradle 
are detected. 

 

7.9 Ensure that the MicroLog 
Receiver is connected to the 
PC and is recognized.  
On the Logger menu, click 
Receiver Beeper On, to 
disable this option. 

Verify that the Receiver no longer 
emits beeps i.e. when receiving 
data from the MicroLog. 
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8 - Help Menu 
 

Test # Test Description Expected Result Result 
8.1 On the Help menu, click 

About MicroLab Plus. 
a. Verify that the About MicroLab 

Plus dialog box window opens. 
b. Verify that the MicroLab Plus 

version number and copyright 
are displayed. 

c. Verify the link 
http://www.fouriersystems.com/ 
works. 

 

8.2. On the Help menu, click 
MicroLog Help. 

Verify that the MicroLog Help file 
opens. 

 

 

9 – Main Toolbar Icons 
 

Test # Icon Test Description and Expected 
Result 

Result 

9.1 Open 

  

Click this icon and refer to test 2.1.  

9.2 Print 

  

Click this icon and refer to test 2.4.  

9.3 Export 

   

Click this icon and refer to test 4.2.  

9.4 Setup 

 

Click this icon and refer to tests 7.1 - 
7.4. 

 

9.5 °C/°F 

  

Click this icon and verify that the units 
on the graph and table in the Offline 
Graph window are toggled between 
Celsius and Fahrenheit. 

 

9.6 Meters View 

 

Click this icon and refer to test 3.2.  

9.7 Multiple Graphs View 

 

Click this icon and refer to test 3.3.  

9.8 Offline  

 

Click this icon and refer to test 3.1.  

9.9 Cradle Map 

 

Click this icon and refer to test 3.4.  

9.10 Scroll Back 

 

Enabled only in Online mode, click this 
icon and verify that the display of Cradle 
units in Meters view scrolls back. 
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Test # Icon Test Description and Expected 
Result 

Result 

9.11 Auto Scroll 

 

Enabled only in Online mode, click this 
icon and verify that the display of Cradle 
units scrolls automatically in Meters 
view. 

 

9.12 Scroll Forward 

 

Enabled only in Online mode, click this 
icon and verify that the display of Cradle 
units in Meters view scrolls forward. 

 

9.13 Alarm 

   

Click this icon to enable/disable the 
sounding of the alarm. Verify by 
referring to test 7.3. 

 

 

10 - Graph Toolbar Icons 
Note: In order to perform the tests in this section, you must be in either Multiple 
Graphs or Offline Graph views. 
 

Test # Icon Test Description Expected Result Result 
10.1 Zoom In 

   

a. Click the Zoom In 
icon.  

b. Click down and 
hold the left mouse 
button and drag the 
Zoom In cursor 
over the area of the 
graph to be 
zoomed.  

c. Release the left 
mouse button to set 
the zoom area. 
Note: Repeat this 
step to continue 
zooming in. Right 
click to zoom out.  

a. Verify that the 
selected area of the 
graph is zoomed in. 

b. Verify that the right 
click option zooms 
out. 

 

10.2 Pan 

   

c. Click the Pan icon. 
d. Place the Pan 

cursor over the 
graph, hold down 
the left mouse 
button and proceed 
to pan the graph 
up, down, left and 
right.  

Verify that the graph 
pans up, down, left and 
right. 

 

10.3 Autoscale 

   

a. Zoom in on an area 
of the graph.  

b. Click the 
Autoscale icon  

Verify that the graph is 
restored and displayed 
in full. 

 

10.4 Cursor 

 

a. Click the Cursor 
icon. 

b. Drag the graph 
cursor to any 
coordinate on the 
graph.  

a. Verify the graph 
cursor is displayed. 

b. Verify that the 
chosen coordinate is 
displayed in the first 
row of the data table. 
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Test # Icon Test Description Expected Result Result 
10.5 Graph 

Properties 

 

Click this icon and refer 
to test 4.1. 

Refer to test 4.1.  

 

11 – Cradle Map Icons 
Note: In order to perform the tests in this section, you must be in Cradle Map view 
and the toolbar must be enabled. 
 

Test # Icon Expected Result Result 
11.1 Lock view 

  

Click the icon and refer to test 5.2.  

11.2 Add Cradle 

  

Click the icon and refer to test 5.3.  

11.3 Remove Cradle 

 

Click the icon and refer to test 5.4.  

11.4 Load Picture   

 

Click the icon and refer to test 5.5.  

 

12 - MicroLog Cradle 
For the purposes of this chapter, ensure that the MicroLog is connected to the PC 
together with the MicroLog Cradle.  
 

Test # Test Description Expected Result Result 
12.1 a. On the Logger menu, 

click Setup Logger. 
b. In the Cradle Info section, 

in the ID field, try to enter 
a value outside of the 
range of 1-200. Then 
enter a value within the 
range. 

c. Click Send Setup. 

Cradle Info Section Verification 
a. Enter the Setup dialog 

box. 
b. Verify that the Cradle Info 

section is enabled. 
c. Verify that it is only possible 

to enter a value within the 1-
200 range in the ID field, and 
that the value entered was 
saved. 

d. Verify that the arrow on the 
Battery Level meter is located 
on the far right of the green 
bar. 

 

12.2 a. On the Logger menu, 
click Setup Logger. 

b. In the Setup section, 
select the Cradle contact 
check box. 
 

a. Enter the Setup dialog 
box. 

b. Verify that the Cradle 
contact drop-down 
menu is enabled 
under the Alarm 
levels section. 
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Test # Test Description Expected Result Result 
12.3 a. On the Logger menu, 

click Setup Logger. 
In the Alarm levels section: 
b. In the Temperature field, 

enter a High value of 10 
°C (well below room 
temp.).  

c. Click Send Setup. 

a. Verify that the Cradle alarm 
works. The temperature 
readings should now exceed 
the High threshold of 10 °C 
defined in the setup and the 
alarm should sound. 

b. Note: To turn off the alarm, 
click Cancel alarm levels in 
the Setup dialog box and 
click Send Setup.  

 

12.4 a. On the Logger menu, 
click Setup Logger. 

In the Cradle time settings 
section: 
b. In the Workday field, use 

the drop-down menus to 
define the operating time 
range for the Cradle 
alarm. The range should 
include the current time 
you are testing the 
Cradle. 

c. In the Alarm delay field, 
use the drop-down menu 
to select the delay 
between the time the 
alarm threshold is crossed 
and the time the alarm will 
sound.  

d. In the Alarm duration field, 
use the drop-down menu 
to select the duration that 
the alarm will sound for. 

e. Click Send Setup. 

a. Enter the Setup dialog 
box. 

b. Verify that all settings 
have been saved.  

c. Verify that the alarm 
sounds in accordance 
with these settings. 

 
 

 

12.4.1 Repeat test 11.4, but in the 
Workday field, select a time 
range which does not cover 
the current time you are 
testing the Cradle. 

Verify that although the alarm 
thresholds are breached, the 
alarm does not sound.  

 

 
 


