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Chapter 1: Introduction 
This manual will guide you through the process of validating the DatPass and 
MicroLab software package to GAMP 4 and FDA Title 21 CFR Part 11 guidelines. 
This manual will provide users with a test plan for their own performance and 
operational qualification of DatPass and MicroLab.  
The manual comprises two main sections. The first section describes the relevant 
sections of the FDA Title 21 CFR Part 11 and the implementation of these sections in 
the fourtec software package. The second section provides the necessary test sheets 
for DatPass and MicroLab.  
It is important to understand that the implementation of these guidelines is not the 
sole responsibility of fourtec. The software user must undertake a large portion of the 
responsibility through the appropriate validation tests. 
 
The software package consists of two programs:  

 DatPass – CFR Administration application 

 MicroLab– Data acquisition and analysis application, supporting fourtec’s 
MicroLog, MicroLogPRO and MicroLite data loggers.  

 
To validate the software package, start by testing DatPass, followed by MicroLab. 
Some of these tests assume that the user is familiar with the Windows interface in 
addition to the DatPass and MicroLab software. 
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Chapter 2: What is Title 21 CFR Part 11? 
The Food and Drug Administration (FDA) issued the regulations Title 21 Code of Federal 
Regulations Part 11. These regulations provide criteria for acceptance by FDA, under certain 
circumstances, of electronic records, electronic signatures, and handwritten signatures 
executed to electronic records as equivalent to paper records and handwritten signatures 
executed on paper. The regulations apply to all FDA program areas, and are intended to 
permit the widest possible use of electronic technology, compatible with FDA’s responsibility 
to promote and protect public health. Part 11 applies to any record governed by an existing 
FDA predicate rule that is created, modified, maintained, archived, retrieved, or transmitted 
using computers and/or saved on durable storage media. 

Title 21 CFR Part 11 Definitions 

Electronic Record 
Any combination of text, graphics, data, audio, pictorial or other information representation in 
digital form, that is created, modified, maintained, archived, retrieved or distributed by a 
computer system. 

Electronic Signature 

A computer data compilation of any symbol or series of symbols, executed, adopted or 
authorized by an individual to be the legally binding equivalent of the individual’s handwritten 
signature. 

Digital Signature 

An electronic signature based upon cryptographic methods of originator authentication, 
computed by using a set of rules and a set of parameters such that the identity of the signer 
and the integrity of the data can be verified. 

Closed System 

An environment in which system access is controlled by persons who are responsible for the 
content of electronic records that is on the system. 

Open System 

An environment in which system access is not controlled by persons who are responsible for 
the content of electronic records that is on the system. 

Standard Operating Procedures (SOPs) 

Guidelines and rules defined by the organization implementing Title 21 CFR Part 11 
compliance to instruct users what they are and are not permitted to do and how they are to 
perform the relevant tasks. 

Fourtec Software 
The dual program software package achieves compliance with FDA Title 21 CFR Part 11 
with: MicroLab and DatPass. The DatPass software is the administration software, which 
includes features that define the users that can log into the MicroLab software, their 
passwords and the digital signatures the users are permitted to sign data within electronic 
records (files). The MicroLab software is used to access the electronic records, display the 
logger data, analyze the data and allow the user to add the appropriate digital signatures to 
the electronic records, in addition to other features.  
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Chapter 3: Compliance with Title 21 CFR Part 11 
 
Title 21 CFR Part 11 Requirements Comments on Compliance or Requirements 

§11.10 Controls for Closed Systems 
(a) Validation of systems to ensure 

accuracy, reliability, consistent 
intended performance, and the 
ability to discern invalid or altered 
records. 

Yes MicroLab will not open invalid or 
altered data.  

(b) The ability to generate accurate 
and complete copies of records in 
both human readable and 
electronic form suitable for 
inspection, review, and copying 
by the agency. 

Yes To ensure data integrity, MicroLab 
stores data with specific formats (mlb 
and mpj). Data can be exported to 

Excel and stored in common 
formats, such as an Excel workbook 
or for example comma delimited or 
tab delimited. Only through the (mlb) 
and (mpj) formats can data be read 
back into MicroLab and only these 
formats support electronic signatures. 

(c) Protection of records to enable 
their accurate and ready retrieval 
throughout the records retention 
period. 

N/A The customer chooses which data 
directory to save files to. Otherwise, 
the default directory C:\Program 
Files\Fourier Systems\MicroLab for 
DatPass\MicroLab Data is used. 
System owners must establish their 
own SOPs to protect and restore data 
files. 

(d) Limiting system access to 
authorized individuals. 

Yes For limited access, the customer must 
purchase a valid software license and 
dongle device, preventing access to 
unauthorized users. 

(e) Use of secure, computer-
generated, time- stamped audit 
trails to independently record the 
date and time of operator entries 
and actions that create, modify, or 
delete electronic records. Record 
changes shall not obscure 
previously recorded information. 
Such audit trail documentation 
shall be retained for a period at 
least as long as that required for 
the subject electronic records and 
shall be available for agency 
review and copying. 

Yes Every action that generates or alters 
an electronic record (mlb or mpj), 
automatically generates an entry into 
an encrypted log file, which can be 
used in audit trail. The entries are 
chronologically organized and cannot 
be edited or deleted. The entries can 
only be viewed using the DatPass 
software. It is the system owner's 
responsibility to create SOPs to 
protect and restore audit trail files. 

(f) Use of operational system checks 
to enforce permitted sequencing 
of steps and events, as 
appropriate 

Yes A smart and user friendly interface 
ensures all MicroLab operations 
follow a specified order. This ensures 
all stages are followed.  

(g) Use of authority checks to ensure 
that only authorized individuals 
can use the system, electronically 
sign a record, access the 
operation or computer system 
input or output device, alter a 
record, or perform the operation 
at hand. 

Yes When using MicroLab, users logon 
with a valid username and password. 
All actions are recorded in an 
encrypted audit trial log file. 
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Title 21 CFR Part 11 Requirements Comments on Compliance or Requirements 

(h) Use of device (e.g. terminal) 
checks to determine, as 
appropriate, the validity of the 
source of data input or 
operational instruction. 

Yes MicroLab checks the status of the 
logger at each communication – 
errors are automatically reported. 

(i) Determination that persons who 
develop, maintain, or use 
electronic record/electronic 
signature systems has the 
education, training, and 
experience to perform their 
assigned tasks. 

N/A System owners must provide their 
authorized users with relevant 
training. 

(j) The establishment of, and 
adherence to, written policies that 
hold individuals accountable and 
responsible for actions initiated 
under their electronic signatures, 
in order to deter record and 
signature falsification. 

N/A System owners must develop written 
policy in which reliability and 
responsibility of each user is 
documented. 

(k) Use of appropriate controls over 
systems documentation including:  

  

(k)(1) Adequate controls over the 
distribution of, access to, and use 
of documentation for system 
operation and maintenance. 

N/A The MicroLab and DatPass Package 
for Title 21 CFR Part 11 compliance 
are supplied with detailed user guides 
and help files, which can be used to 
create SOP. Distribution, access and 
implementation of this documentation 
are the responsibility of the system 
owner. 

(k)(2) Revision and change control 
procedures to maintain an audit 
trail that documents time- 
sequenced development and 
modification of systems 
documentation. 

N/A This is the responsibility of the system 
owner. 

§11.30 Controls for Open Systems 
 Persons who use open systems 

to create, modify, maintain, or 
transmit electronic records shall 
employ procedures and controls 
designed to ensure the 
authenticity, integrity, and, as 
appropriate, the confidentiality of 
electronic records from the point 
of their creation to the point of 
their receipt. Such procedures 
and controls shall include those 
identified in §11.10, as 
appropriate, and additional 
measures such as document 
encryption and use of appropriate 
digital signature standards to 
ensure, as necessary under the 
circumstances, record 
authenticity, integrity, and 
confidentiality. 

N/A MicroLab has been implemented as a 
closed system. 
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Title 21 CFR Part 11 Requirements Comments on Compliance or Requirements 

§11.50 Signature Manifestations 
(a) Signed electronic records shall 

contain information associated 
with the signing that clearly 
indicates all of the following: 

  

(a)(1) The printed name of the signer; Yes Stored and printed data contains: 
User login name, time/date stamp, 
and user signature meaning(s).  

(a)(2) The date and time when the 
signature was executed; 

Yes  

(a)(3) The meaning (such as review, 
approval, responsibility, or 
authorship) associated with the 
signature 

Yes  

(b) The items identified in paragraphs 
(a)(1),(a)(2), and (a)(3)of this 
section shall be subject to the 
same controls as for electronic 
records and shall be included as 
part of any human readable form 
of the electronic record (such as 
electronic display or printout). 

Yes Electronic signatures in MicroLab are 
subject to the same requirements as 
electronic records. Electronic 
signatures can be viewed 
electronically and can be included on 
a printout. 

§11.70 Signature/Record Linking 
 Electronic signatures and 

handwritten signatures executed 
to electronic records shall be 
linked to their respective 
electronic records to ensure that 
the signatures cannot be excised, 
copied or otherwise transferred so 
as to falsify an electronic record 
by ordinary means. 

Yes In MicroLab, raw data and electronic 
signatures are permanently linked in a 
single file, and as such cannot be 
edited, deleted or separated. 

§11.100 General Requirements 
(a) Each electronic signature shall be 

unique to one individual and shall 
not be reused by, or reassigned 
to, anyone else. 

Yes DatPass software contains an 
authorized user list containing login 
name, password, and meanings list, 
making every user unique to the 
system. 

(b) Before an organization 
establishes, assigns, certifies or 
otherwise sanctions an 
individual's electronic signature, 
or any element of such electronic 
signature, the organization shall 
verify the identity of the individual. 

N/A This is the responsibility of the system 
owner. 

(c) Persons using electronic 
signatures shall, prior to or at the 
time of such use, certify to the 
agency that the electronic 
signatures in their system, used 
on or after August 20, 1997, are 
intended to be the legally binding 
equivalent of traditional 
handwritten signatures. 

N/A This is the responsibility of the system 
owner. 
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Title 21 CFR Part 11 Requirements Comments on Compliance or Requirements 

(c)(1) The certification shall be 
submitted in paper form, and 
signed with a traditional 
handwritten signature, to the 
Office of Regional Operations 
(HFC-100),5600 Fishers Lane, 
Rockville, MD 20857.  

N/A This is the responsibility of the system 
owner. 

(c)(2) Persons using electronic 
signatures shall, upon agency 
request, provide additional 
certification or testimony that a 
specific electronic signature is the 
legally binding equivalent of the 
signer's handwritten signature. 

N/A This is the responsibility of the system 
owner. 

§11.200 Electronic Signature Components and Controls 
(a) Electronic signatures that are not 

based upon biometrics shall: 
  

(a)(1) Employ at least two distinct 
identification components such as 
an identification code and 
password. 

Yes DatPass Software for Title 21 CFR 
Part 11 compliance uses a unique 
dual component combination: Login 
username and password. Every login 
and new digital signature with 
MicroLab requires a valid username 
and password. MicroLab enforces the 
user to re-logon after a time period, 
which is defined by the administrator 
via the DatPass software. 

(a)(1)(i) When an individual executes a 
series of signings during a single, 
continuous period of controlled 
system access, the first signing 
shall be executed using all 
electronic signature components; 
subsequent signings shall be 
executed using at least one 
electronic signature component 
that is only executable by, and 
designed to be used only by, the 
individual 

Yes  

(a)(1)(ii) When an individual executes one 
or more signings not performed 
during a single continuous period 
of controlled system access, each 
signing shall be executed using 
all of the electronic signature 
components. 

Yes  

(a)(2) Be used only by their genuine 
owners; 

N/A Information confidentiality is the 
responsibility of the system owner 
and users. 

(a)(3) Be administered and executed to 
ensure that attempted use of an 
individual's electronic signature 
by anyone other than its genuine 
owner requires collaboration of 
two or more individuals. 

N/A Information confidentiality is the 
responsibility of the system owner 
and users. 
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Title 21 CFR Part 11 Requirements Comments on Compliance or Requirements 

(b) Electronic signatures based upon 
biometrics shall be designed to 
ensure that they cannot be used 
by anyone other than their 
genuine owners. 

N/A Biometrics are not the basis of 
electronic signatures generated by 
DatPass software for Title 21 CFR 
Part 11 compliance.  

§11.300 Controls for Identification Codes/Passwords 
 Persons who use electronic 

signatures based upon use of 
identification codes in 
combination with passwords shall 
employ controls to ensure their 
security and integrity. Such 
controls shall include: 

  

(a) Maintaining the uniqueness of 
each combined identification code 
and password, such that no two 
individuals have the same 
combination of identification code 
and password. 

Yes Since every user is unique in the 
MicroLab and DatPass systems, 
duplicate combinations of username 
and password are impossible. 

(b) Ensuring that identification code 
and password issuances are 
periodically checked, recalled, or 
revised, (e.g. to cover such 
events as password aging). 

Yes Adequate aging of passwords is the 
responsibility of the system owner. 
MicroLab allows authenticated users 
to change their own logon password.  

(c) Following loss management 
procedures to electronically 
deauthorize lost, stolen, missing, 
or otherwise potentially 
compromised tokens, cards, and 
other devices that bear or 
generate identification code or 
password information, and to 
issue temporary or permanent 
replacements using suitable, 
rigorous controls. 

N/A Unauthorized access is vetoed by the 
DatPass software since an 
administrator can disable or remove 
any user from the system. 

(d) Use of transaction safeguards to 
prevent unauthorized use of 
passwords and/or identification 
codes, and to detect and report in 
an immediate and urgent manner 
any attempts at their 
unauthorized use to the system 
security unit, and, as appropriate, 
to organizational management.  

Yes All unsuccessful logons are recorded 
in the audit trail log file. 

(e) Initial and periodic testing of 
devices, such as tokens or cards, 
that bear or generate 
identification code or password 
information, to ensure that they 
function properly and have not 
been altered in an unauthorized 
manner. 

N/A This is the responsibility of the system 
owner. 

References 
For further information on FDA Title 21 CFR Part 11, please visit the FDA website: 
www.fda.gov 
For FDA guidance documents: 
www.fda.gov/ora/compliance_ref/part11/ 
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Chapter 4: DatPass Validation Tests 
 

1 - Initial Login 
Following DatPass installation, you will be required to start the 30-day free trial period 
or to activate the software using the unique product serial number supplied with the 
software CD. Until either of these actions is performed, the user won’t be able to 
login to DatPass.  

Note: Following installation, the first user to login to the DatPass software is 
automatically assigned the user name Admin. He is classified as an Administrator.  

 

Test # Test Description Expected Result Result 

1.1 Double click the DatPass 
shortcut on the Desktop. 

Verify that the User Login dialog box 
opens. 

 

1.2 Click New User in the login 
window. 

a. Verify that the New User Login 
window opens. 

b. Verify that the New User drop-
down menu displays the Admin 
user name. 

 

1.3 a. Populate the New User 
ID, Confirm User ID, 
New Password and 
Confirm Password fields, 
and click OK. 

b. Exit the DatPass 
software. 

c. Launch the DatPass 
software. 

a. Once DatPass is launched, 
verify that the User Login 
window opens. 

b. Verify that the newly created 
User ID and User Password are 
correct (click OK and verify 
successful login to DatPass). 

 

 

2 - File Menu 
 

Test # Test Description Expected Result Result 

2.1 On the File menu, click Open. 
Navigate to: 
C:\Users\Public\fourtec\DatPass.  
Note: You will only find 
database files saved in this 
directory if previous database 
data, such as the Audit Trail log, 
has been saved.  

a. Verify that the Open 
dialog box opens.  

b. Select a file to open, 
and click Open. 

c. Verify that the 
database file (file 
extension .mdb) 
opens, and the table 
data is displayed in the 
main DatPass window.  

 

2.2 On the File menu, click New. Verify that the DatPass main 
window is clear of all previous 
Audit Trail data. 

 

2.3 On the File menu, click Print. 
Note: For this action to succeed, 
the main DatPass window must 
be populated with Audit Trail log 
data.  

Verify that the Print Dialog dialog 
box opens. 

 



 - 11 - 

Test # Test Description Expected Result Result 

2.4 On the File menu, click Print 
Setup. 

Verify that the Print Setup dialog 
box opens. 

 

2.5 On the File menu, click Log off. Verify that the User Login dialog 
box opens. 

 

3 - Administration 

 
Test # Test Description Expected Result Result 

3.1 On the Administration 
menu, click User 
Administration.  

a. Verify that the User 
Administration dialog box opens. 

b. Verify that Admin appears under 
the User Name tab and 
Administrator appears under the 
Group tab.  

 

3.1.1 a. In the User 
Administration dialog 
box, click Add User. 

b. Enter a new user name 
in the User Name field. 

c. Select a Group from the 
Group drop-down menu: 
Administrator, Approver, 
or User. 

Under the Login Settings 
heading: 
d. Enter a number in the 

Password min length 
field (for example, 4). 

e. Enter a number in the 
User ID min length field 
(for example, 4). 

f. Enter number of days in 
the Password expiration 
time (days) field (for 
example, 1). 

g. Use the drop-down 
menu in the Inactivity 
Timeout field to select 
the duration (for 
example, 00:05:00). 

h. Click OK. 

Verify that a new user has been 
added to the User Administration 
dialog box, listing the correct User 
Name and Group. 

 

3.1.2 a. Launch the DatPass 
software and add click 
New User.  

b. Using the new user 
account created in test 
3.1.1, fill in the New User 
ID, Confirm New User 
ID, New Password and 
Confirm Password fields.  

c. Click OK.  

Verify that the DatPass software 
opens. 
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Test # Test Description Expected Result Result 

3.1.3 Launch the DatPass 
software. In the User Login 
dialog box: 
a. Enter an incorrect user 

name and a correct 
password. 

b. Enter a correct user 
name and an incorrect 
password. 

c. Enter an incorrect user 
name and password.  

Verify that in all three login tests, the 
DatPass software does not open. 

 

3.2 In the User Administration 
dialog box, select the newly 
added user (see test 3.1.1) 
and click Properties. 

a. Verify that the User Properties 
dialog box opens. 

b. Verify that the properties entered 
when adding the user (in test 
3.1.1) are correct. 

 

3.2.1 a. In the User Properties 
dialog box, change the 
user group using the 
drop-down menu in the 
Group field. For 
example, from User to 
Approver). 

b. Click OK.  

Verify that the user group was 
successfully changed by reopening 
the User Properties dialog box and 
checking the Group field.  

 

3.2.2 a. In the User Properties 
dialog box, change the 
Login Settings. 

b. Click OK. 

Verify that the Login Settings were 
successfully changed by reopening 
the User Properties dialog box and 
checking the relevant Login 
Settings.  

 

3.3 In the User Administration 
dialog box, select a user and 
click Deactivate. 

Verify that the user icon is now 
marked with a white cross in a red 

background, as follows:   

 

3.3.1 Open the DatPass software 
and attempt to login with the 
user name and password of 
the newly deactivated user.  

Verify that a dialog box opens with 
the message:  
Your user account was deactivated. 
Please refer to your system 
administrator. 

 

3.3.2 a. In the User 
Administration dialog 
box, select the 
previously deactivated 
user and click Activate. 

b. Exit DatPass, then 
reopen DatPass and 
login with the user name 
and password of the 
newly activated user. 

Verify that you are able to 
successfully login to DatPass.  
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Test # Test Description Expected Result Result 

3.3.3 a. In the User 
Administration dialog 
box, select a user and 
click Renew Password. 

b. Exit DatPass, and then 
reopen DatPass and 
attempt to login with that 
user. 

a. Verify that a new DatPass dialog 
box opens with the message:  
Your password was reset. 
Please enter a new password. 

b. After clicking OK, verify that a 
new Change Password dialog 
box opens. 

 

3.3.4 a. In the Change Password 
dialog box, enter a new 
password and then 
confirm this password. 

b. Click OK. 

Verify that the DatPass software 
opens. 

 

3.3.5 Launch the DatPass 
software and login using the 
user name and new 
password created in step 
3.3.4. 

Verify that the DatPass software 
opens. 

 

3.4 On the Administration 
menu, click Group 
Administration.  

a. Verify that the Group 
Administration dialog box opens. 

b. Verify that the group names 
User, Approver and 
Administrator are displayed. 

 

3.4.1 In the Group Administrator 
dialog box, click Add Group. 

Verify that the Group Properties 
dialog box opens. 

 

3.4.2 a. In the Group Properties 
dialog box, enter a new 
name in the Group 
Name field. 

b. Click the New check box. 
c. Click OK. 

a. Verify that the Group 
Administration dialog box opens. 

b. Verify that the newly created 
group is displayed in the Group 
Name list. 

 

3.4.3 In the Group Administrator 
dialog box, select the newly 
created group and click 
Properties. 

Verify that there is only one check 
box selected (in this case, New).  

 

3.4.4 In the Group Administrator 
dialog box, select one of the 
listed groups and click 
Remove Group. 
Note: You will not be able to 
remove a group if there are 
still users who are members 
of this group. 

a. Verify that a dialog box opens 
with the message:  
Are you sure you want to 
remove <Group Name> group? 

b. Click Yes. 

 

3.4.5 On the Administration 
menu, click Group 
Administration.  

Verify that the group you have 
removed is no longer displayed in 
the Group Name list. 

 

 

4 - Help 
 

Test # Test Description Expected Result Result 

4.1 On the Help menu, click 
DatPass User Guide.  

Verify that the DatPass v4.0 User 
Guide is opened (file name: User 
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Guide.pdf) 

4.2 On the Help menu, click 
Register. 

a. Verify that the Validata – 
Product Validataion window is 
opened. 

b. DatPass will either be in the Trial 
mode, or will already be 
activated. 

 

4.3 On the Help menu, click 
About DatPass.  

c. Verify that DatPass version 
4.0.0.0 is displayed. 

d. Verify the link 
http://www.fourtec.com works. 

 

 

5 - Toolbar Icons 
 

Test # Icon Test and Expected Result Result 

5.1 Open 

 

Refer to test 2.1.  

5.2 Print 

 

Refer to test 2.3.  

5.3 User Administration 

 

Refer to tests 3.1 to 3.3.  

5.4 Group Administration 

 

Refer to test 3.4.   

5.5 Refresh  

 

a. Perform at least one action in 
the MicroLab software and click 
Refresh. 

b. Verify that the Audit Trail data 
has been refreshed (you will see 
new actions added to the table). 

 

 
 
 
 

http://www.fourtec.com/
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Chapter 5: MicroLab Validation Tests 

1 - Login 
 

Test # Test Description Expected Result Result 

1.1 a. Launch the MicroLab 
software. The User Login 
dialog box opens. 

b. In the User ID field, enter 
the User ID created in 
test 1.3 of the DatPass 
Validation Test. 

c. In the User Password 
field, enter an incorrect 
password. 

Verify that the MicroLab software 
does not open and an Incorrect 
Password message window 
opens. 

 

1.2 a. In the User Login dialog 
box, in the User ID field, 
enter an incorrect User 
ID.  

b. In the User Password 
field, enter the User 
Password created in test 
1.3 of the DatPass 
Validation Test. 

Verify that the MicroLab software 
does not open and an Incorrect 
User ID message window opens. 

 

1.3 In the User Login dialog box, 
enter an incorrect User ID 
and User Password.  

Verify that the MicroLab software 
does not open and an Incorrect 
User ID message window opens. 

 

1.4 In the User Login dialog box, 
login using the User ID and 
User Password created in 
test 1.3 of the DatPass 
Validation Test. 

Verify that the MicroLab software 
is launched. 

 

 

2 - File Menu 
 

Test # Test Description Expected Result Result 

2.1 On the File menu, click 
New. 

Verify that the MicroLab main 
window is clear i.e. there is no 
data in the graph and table in the 
main window. 

 

2.2 On the File menu, click 
Open. 

Verify that the Open dialog box 
opens.  

 

2.2.1 In the Open dialog box, 
select a file and click Open. 

Verify that the selected file opens, 
and that the appropriate data is 
displayed in the graph and table in 
the main window. 

 

2.3 On the File menu, click 
Save As. 

Verify that the Save As dialog box 
opens. 
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Test # Test Description Expected Result Result 

2.3.1 a. In the Save As dialog 
box, in the File name 
field, enter the name of 
the file to be saved.  

b. Click Save. 

a. Verify that the file was actually 
saved. Navigate to: 
C:\Programs Files\Fourier 
Systems\MicroLab for 
DatPass\MicroLab Data. 

b. Verify that the file was saved 
in the MicroLab folder. 

 

2.4 On the File menu, click 
Display Properties.  

Verify that the Display properties 
dialog box opens. 

 

2.4.1 Under the Decimal place 
settings heading in the 
Display Properties dialog 
box: 
a. Change the 

Temperature data field 
to 3. 

b. Change the Humidity 
data field to 2. 

c. Change the External 
data field to 1. 

d. Click OK. 

Verify that in the data table in the 
main MicroLab window, the 
decimal places for the 
temperature and humidity data 
(and any external sensors) have 
been updated accordingly.  

 

2.4.2 In the Display properties 
dialog box, under the Date 
format settings heading are 
four options for the date 
format. 
Click on any one of the 
formats not already 
selected.  

a. Verify that for the graph in the 
main MicroLab window, the 
Time (x) axis has been 
updated accordingly.  

b. Verify that for the data table in 
the main MicroLab window, 
the Time (Date) column has 
been updated accordingly. 

 

2.5. On the File menu, click 
Print. 

Verify that the Print options dialog 
box opens. 

 

2.5.1 In the Print options dialog 
box, click the Graph radio 
button. 

Verify that the Report data 
selection option is disabled. 

 

2.5.2 In the Print options dialog 
box:  
a. Click the Graph radio 

button. 
b. Click Print. 

Verify that the Print dialog box 
opens. 

 

2.5.2.1 In the Print dialog box, 
confirm that the correct 
printer is selected in the 
Name drop-down menu and 
click OK. 

Verify that the graph was printed 
at the selected printer.  

 

2.5.3 In the Print options dialog 
box: 
a. Click the Table radio 

button. 
b. Under the Report data 

selection heading, 
ensure the Print all data 
check box is selected.  

c. Click Print. 

Verify that the Print dialog box 
opens. 
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Test # Test Description Expected Result Result 

2.5.3.1 In the Print dialog box, 
confirm that the correct 
printer is selected in the 
Name drop-down menu and 
click OK. 

Verify that the graph was printed 
with all of its data (as defined in 
test 2.5.3), at the selected printer. 

 

2.5.4 In the Print options dialog 
box: 
a. Click the Table radio 

button. 
b. Under the Report data 

selection heading, 
ensure the Print all data 
check box is not 
selected, thereby 
enabling the From and 
To fields. 

c. Using the From and To 
fields, define the date 
and time range to print. 

d. Click Print. 

Verify that the Print dialog box 
opens.  
 

 

2.5.4.1 In the Print dialog box, 
confirm that the correct 
printer is selected in the 
Name drop-down menu and 
click OK. 

Verify that the graph was printed 
with the specific date and time 
range (as defined in test 2.5.4), at 
the selected printer. 

 

2.6 On the File menu, click 
Print Setup. 

Verify that the Print Setup dialog 
box opens. 

 

2.7 On the File menu, click Log 
Off. 

Verify that the User Login dialog 
box opens. 

 

 

3 - View Menu 
 

Test # Test Description Expected Result Result 

3.1 On the View menu, click 
Display Data map to 
unselect it (removing the tick 
by the menu entry). 

Verify that the Data Map pane has 
been removed from the left of the 
main MicroLab window. 

 

3.2 On the View menu, click 
Display Graph to unselect it 
(removing the tick by the 
menu entry). 

Verify that the graph has been 
removed from the center of the 
main MicroLab window. 

 

3.3 On the View menu, click 
Display Table to unselect it 
(removing the tick by the 
menu entry). 

Verify that the table has been 
removed from the right of the main 
MicroLab window. 
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4 - Graph Menu 

Note: In order to perform the tests in this section, a graph must be displayed in the 
main MicroLab window. Refer to test 2.2 regarding opening a file. 

 

Test # Test Description Expected Result Result 

4.1 a. On the Graph menu, 
click Graph Properties. 

b. Ensure that Time is 
selected in the Select 
axis drop down menu.  

c. Ensure the Auto scale 
check box is not 
selected, thereby 
enabling the From and 
To fields. 

d. Using the From and To 
fields, define a new date 
and time range. 

e. Click OK. 

Verify that the time scale of the 
graph in the main MicroLab 
window has been updated 
accordingly. 

 

4.1.1 a. In the Graph properties 
dialog box, click Set 
default zoom. 

b. In the Default zoom 
setting dialog box, enter 
a time range in the Start 
and End fields.  

c. Click Set. 
d. Click the Use default 

zoom check box. 
e. Click OK. 

Verify that the time scale of the 
graph in the main MicroLab 
window has been updated 
accordingly. 

 

4.1.2 a. In the Graph properties 
dialog box, select 
Temperature in the 
Select axis drop-down 
menu. 

b. The Min and Max 
temperature 
fields are now 
active. Enter –26 
in the Min field 
and 22 in the 
Max field. 

c. Click OK. 

Verify that the temperature scale 
of the graph in the main MicroLab 
window has been updated 
accordingly. 

 

4.1.3  a. In the Graph properties 
dialog box, click the 
Lines tab. 

b. Select Time in the Select 
plot drop-down menu. 

c. Change the X Axis color 
to red, by using the Color 
drop-down menu. 

Verify that the Time axis of the 
graph in the main MicroLab 
window is now red.  
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Test # Test Description Expected Result Result 

4.1.4 a. In the Graph properties 
dialog box, click the 
Lines tab. 

b. Select Temperature in 
the Select plot drop-
down menu. 

c. Under the Line heading, 
ensure the Visible check 
box is selected. 

d. Change the Temperature 
axis color to green, using 
the Color drop-down 
menu. 

e. Using the Style drop-
down menu, select the 
solid line option. 

f. Using the Weight drop-
down menu, select the 
thinnest line option. 

In the graph in the main MicroLab 
window, verify that the 
Temperature axis is green and the 
line plotting the temperature data 
is green, solid and thin.  

 

4.1.5 For MicroLog EC650 and 
MicroLogPRO EC750 only: 
a. In the Graph properties 

dialog box, click the 
Lines tab. 

b. Select Humidity in the 
Select plot drop-down 
menu. 

c. Under the Line heading, 
ensure the Visible check 
box is selected. 

d. Change the Humidity 
axis color to yellow, 
using the Color drop-
down menu. 

e. Using the Style drop-
down menu, select the 
solid line option. 

f. Using the Weight drop-
down menu, select the 
thinnest line option. 

In the graph in the main MicroLab 
window, verify that the Humidity 
axis is yellow and the line plotting 
the humidity data is yellow, solid 
and thin.  

 

4.1.6 a. In the Graph properties 
dialog box, click the 
Lines tab. 

b. Click Restore defaults. 

Verify that all axis and line defaults 
have been restored in the graph in 
the main MicroLab window.  

 

4.2 On the Graph menu, click 
Export Graph to Excel. 

Verify that the displayed graph is 
exported to Excel. 
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Test # Test Description Expected Result Result 

4.3 a. On the Graph menu, 
click Zoom. 

b. Click down and hold the 
left mouse button and 
drag the Zoom cursor 
over the area of the 
graph to be zoomed.  

c. Release the left mouse 
button to set the zoom 
area. 

Verify that the selected area of the 
graph is zoomed in. 

 

4.4 On the Graph menu, click 
Autoscale. 

Verify that the graph in the main 
MicroLab window is restored and 
displayed in full.  

 

4.5 a. On the Graph menu, 
click Crop. 

b. Click down and hold the 
left mouse button and 
drag the Crop cursor 
over the area of the 
graph to be cropped. 

c. Release the left mouse 
button to crop the 
selected area. 

Verify that the selected area of the 
graph has been cropped – only the 
selected area should be visible.  

 

4.6 a. On the Graph menu, 
click Copy Graph.  

b. Paste the graph into 
another application such 
as Microsoft Office 
Word.  

Verify that the graph has been 
successfully copied.  

 

4.7 On the Graph menu, click 
Dew Point and select 
Internal Temperature.  

Verify that the dew point is shown 
on the graph in the main MicroLab 
window. 

 

 

5 - Logger Menu 
Note: Ensure that the data logger (MicroLog, MicroLogPRO or MicroLite) is 
connected to the PC and is recognized by the MicroLab software. 
 

Test # Test Description Expected Result Result 

5.1 a. On the Logger menu, 
click Setup Logger. 

b. In the MicroLog/MicroLite 
info section of the Setup 
dialog box, enter a new 
name to identify the data 
logger in the Comment 
field.  

c. Click Send Setup.  

MicroLog/MicroLite Info Section 
Verification 
a. Enter the Setup dialog 

box and verify that the 
Comment field is 
correctly updated. 

b. Verify that the S/N is 
correct for the logger 
that is currently 
connected to MicroLab.  

c. Verify that the logger 
firmware version 
number is displayed. 

d. Verify that the arrow on 
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Test # Test Description Expected Result Result 

the Battery Level meter 
is located on the far 
right of the green bar 
(for full batteries). 

 

5.2 a. On the Logger menu, 
click Setup Logger. 

In the Setup section of the 
Setup dialog box:  
b. Click either the º C or º F 

radio button next to the 
Temperature unit 
heading.  

c. In the Interval 
(hh:mm:ss) field, select 
the time interval for 
MicroLog sampling (from 
10 secs to 2 hours for 
MicroLog or from every 
second to 2 hours for 
MicroLite). 

d. Click the Timer run check 
box. Using the Timer run 
date and time fields, set 
the time for the data 
logger to begin sampling.  

e. Click Send Setup.  

Setup Section Verification 
a. Enter the Setup dialog 

box. 
b. If the connected logger 

comes with both 
Temperature and 
Humidity internal 
sensors, verify that 
both of the check 
boxes for these 
sensors are selected. 

c. If the connected logger 
only comes with the 
Temperature internal 
sensor, verify that the 
check box for this 
sensor is selected and 
that the Humidity and 
External sensor check 
boxes are not selected 
(and N/A is displayed).  

d. Verify that when the 
Interval is adjusted 
(test 5.2c), the 
Recording time also 
self-adjusts.  

e. Verify that all updates 
made in test 5.2 have 
been updated in the 
Setup dialog box.  

f. After exiting the Setup 
dialog box, download 
the logger data and 
verify (in the data table) 
that the data date and 
time range, as well as 
the data interval, 
correspond with what 
you defined in Setup. 
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Test # Test Description Expected Result Result 

5.3 a. On the Logger menu, 
click Setup Logger. 

In the Alarm levels section of 
the Setup dialog box:  
b. Enter new Low and High 

values in the 
Temperature and 
Humidity fields.  

c. Click Send Setup. 
d. Download data from the 

logger into MicroLab, so 
that the data is displayed 
in a graph in the main 
MicroLab window.  

e. Click the Show Alarm 

levels icon  in the 
MicroLab tool bar. Select 
Temperature from the 
adjacent drop-down 
menu, and then select 
Humidity (if connected 
logger has a humidity 
sensor).   

a. In the main MicroLab window, 
verify that the Low and High 
alarm levels for both 
Temperature and Humidity (if 
relevant) appear on the graph 
as a light blue and light red 
line respectively.  

b. Verify that these alarm levels 
correspond to the alarm levels 
previously defined in the 
Setup. 

  

 

5.3.1 a. On the Logger menu, 
click Setup Logger. 

In the Alarm levels section of 
the Setup dialog box:  
b. Click Cancel alarm 

levels to restore the 
default levels adjusted in 
test 4.2.  

c. Click Send Setup. 
d. Repeat tests 5.3d and 

5.3e above. 

a. In the MicroLab main window, 
verify that the Low and High 
alarm levels for both 
Temperature and Humidity (if 
relevant) appear on the graph 
as a light blue and light red 
line respectively. 

b. Verify that the default alarm 
levels have been restored as 
follows: 
MicroLog:  
Temperature: Low: -30 °C/-22 
°F, High: 50 °C/122 °F 
Humidity: Low: 0, High: 100 
MicroLogPRO:  
Temperature: Low: -40 °C/-40 
°F, High: 80 °C/176 °F 
Humidity: Low: 0, High: 100 
MicroLite:  
Temperature: Low: -40 °C/-40 
°F, High: 80 °C/176 °F 

 

5.4 a. On the Logger menu, 
click Setup Logger. 

b. In the Setup dialog box, 
click Send Setup. 

 

a. Verify that the message: Setup 
will clear the 
MicroLog/MicroLite memory. 
Do you want to continue? 
appears. Click Yes. 

b. Verify that the Reason Dialog 
box opens. Enter a reason for 
performing this action e.g. 
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Test # Test Description Expected Result Result 

Test. 
c. Verify that the Status window 

opens and that all statuses are 
successfully sent (noted with a 
green check mark). A 
Completed status should 
appear at the bottom of this 
window.  

d. Click Close. 
 
Note: The Set Cradle status will 
only be sent if a Cradle is 
connected and recognized by the 
MicroLab.  

5.5 On the Logger menu, click 
Download. 

Verify that the logger data is 
downloaded into the MicroLab 
main window. 
Note: Ensure that the logger has 
been recording data to download. 

 

5.6 On the Logger menu, click 
Run. 

a. Verify that the message: Run 
will clear the 
MicroLog/MicroLite memory. 
Do you want to continue? 
appears.  

b. Verify that the Reason Dialog 
box opens. Enter a reason for 
performing this action e.g. 
Test. 

c. Verify that the logger is 
recording data. 

 

5.7 On the Logger menu, click 
Stop. 

a. Verify that the Reason Dialog 
box opens. Enter a reason for 
performing this action e.g. 
Test. 

b. Verify that the logger is in Stop 
mode and is not recording 
data. 

 

5.8  On the Logger menu, click 
Set Celsius. 

Verify that the temperature data is 
shown in the logger LCD display 
in Celsius.  

 

5.9 On the Logger menu, click 
Set Fahrenheit. 

Verify that the temperature data is 
shown in the logger LCD display 
in Fahrenheit. 

 

5.10 On the Logger menu, click 
Com Setup. 
 

a. Verify that the Communication 
Setup dialog box opens. 

b. Verify that the logger you have 
connected to the PC is 
identified. The check box for 
the port to which the logger is 
connected should be selected. 
Verify that the message 
MicroLog/MicroLite is 
connected appears. 
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Test # Test Description Expected Result Result 

5.10.1 On the Logger menu, click 
Com Setup. 
In the Communication Setup 
dialog box, click Try to 
connect. 

a. Verify that the PC ports are 
being scanned. 

b. Verify that a confirmation 
message appears indicating 
that the MicroLog/MicroLite is 
detected. 

 

6 - Help Menu 
 

Test # Test Description Expected Result Result 

6.1. On the Help menu, click 
About MicroLab. 

a. Verify that the About MicroLab 
dialog box window opens. 

b. Verify that the MicroLab version 
number and copyright are 
displayed. 

c. Verify the link 
http://www.fouriersystems.com/ 
works. 

 

6.2. On the Help menu, click 
MicroLog Help. 

Verify that the MicroLog Help file 
opens. 

 

7 – Main Toolbar Icons 
 

Test # Icon Test Description and Expected 
Result 

Result 

7.1 Open 

  

Click this icon and refer to test 2.2.  

7.2 Save 

 

a. Clicking the Save icon will save the 
current data.  

b. Verify that the data was saved by 
following test 2.2 and opening the 
data file which was just saved. 

 

7.3 Print 

  

Click this icon and refer to test 2.5.  

7.4 Export 

   

Click this icon and refer to test 4.2.  

7.5 Run 

 

Click this icon and refer to test 5.6.  

7.6 Stop 

   

Click this icon and refer to test 5.7.  

7.7 Setup 

 

Click this icon and refer to tests 5.1 - 
5.4. 

 

7.8 Download Click this icon and refer to test 5.5.  

http://www.fouriersystems.com/
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Test # Icon Test Description and Expected 
Result 

Result 

   
7.9 Data Map 

   

Click this icon and refer to test 3.1.  

7.10 Graph 

   

Click this icon and refer to test 3.2.  

7.11 Table 

 

Click this icon and refer to test 3.3.  

7.12 Statistics 

 

Click this icon and verify that statistics 
such as Min, Max and Average values 
appear on the bottom of the graph. 

 

7.13 °C/°F 

  

Click this icon and verify that the units 
on the graph and table are toggled 
between Celsius and Fahrenheit. 

 

7.14 Alarm 

   
Data select (for Alarm) 

  

Click this icon and refer to test 5.3.  

 

8 - Graph Toolbar Icons 
 

Test # Icon Test Description Expected Result Result 

8.1 Zoom In 

   

a. Click the Zoom In 
icon.  

b. Click down and 
hold the left mouse 
button and drag the 
Zoom In cursor 
over the area of the 
graph to be 
zoomed.  

c. Release the left 
mouse button to set 
the zoom area. 
Note: Repeat this 
step to continue 
zooming in. Right 
click to zoom out.  

a. Verify that the selected 
area of the graph is 
zoomed in. 

b. Verify that the right 
click option zooms out. 
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8.2 Pan 

   

a. Click the Pan icon. 
b. Place the Pan 

cursor over the 
graph, hold down 
the left mouse 
button and proceed 
to pan the graph 
up, down, left and 
right.  

Verify that the graph pans 
up, down, left and right. 

 

8.3 Auto scale 

   

a. Zoom in on an area 
of the graph.  

b. Click the Auto 
scale icon  

Verify that the graph is 
restored and displayed in 
full. 

 

8.4 Cursor 

 

a. Click the Cursor 
icon. 

b. Drag the graph 
cursor to any 
coordinate on the 
graph.  

a. Verify the graph cursor 
is displayed. 

b. Verify that the chosen 
coordinate is displayed 
in the first row of the 
table in the MicroLab 
main window. 

 

8.5 Graph 
Properties 

 

Click this icon and refer 
to tests 4.1 and 4.2. 

Refer to test 4.1.  

 


